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Chapter 1: Getting Started

This guide includes combined instructions for both New and Upgrade installations of MIP Fund Accounting.

New Installation Scenarios

You are installing a one-user version of MIP (programs and database) on a single computer. The

computer may or may not be part of a network, but the programs and database reside on the local hard

drive of this computer. In this scenario, there are no network files involved, and no other computers have

access to the system/database. Optional, IIS Web Server running on the single computer* or separately

if connected to your network.

You have a network comprised of a server machine with one or more local computers attached, and you

want to install the database on the server machine so that other users can access it from their local

computers (either one at a time or simultaneously depending on your license). Optional, IIS Web Server

running on separate server on your network.

You have a network comprised of two or more local computers that can access each other's shared

drives, and you want to install the database on one computer's shared drive so that other users can

access it from their local computers (either one at a time or simultaneously depending on your license).

Optional, IIS Web Server running on separate server on your network.

You have a network and want to install the database on a server machine for backup and security

purposes, even though only one user accesses it from a single local computer. Optional, IIS Web Server

running on separate server on your network.

You are installing theMIP programs and database in a virtual environment. Youmust use a virtual service

client, such as VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

Optional, IIS Web Server running on a separate server within the virtual environment.

Upgrade Installation Scenarios

You are upgrading an existing Stand Alone or Network installation. Your installation will upgrade if you

have a previous version installed.

You are upgrading theMIP programs and database in a virtual environment. Youmust use a virtual

service client, such as VMWare's Infrastructure Client Console, instead of a Remote Desktop

Connection.
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For specific information regarding existing users, see "Existing User - Upgrading" (page 23), "Existing

User - Server Install" (page 27), and "Existing User -Workstation Install" (page 36).

Optional Alerts IIS Server Installation Scenarios

The Alerts installation will work with any of the above scenarios for Stand Alone or Network installation.

It is a common practice to have a separate IIS Web server as a part of your network so that your

SQL Server will not experience additional performance delays when processing transactions or running

reports.

If the IIS Web Server is installed on the same computer along with theMIP programs and database, you

could experience connection limitations and possible performance delays when processing transactions

and running reports.

If IIS Web Server is on amachine using aWindows 7, 8.1, or 10 Operating System, the system has a 10

concurrent connection limitation. This is a knownMicrosoft restriction when usingWindows 7, 8.1, or 10

as the Alerts Server. It is recommended that you use a separate server on your network as your IIS Web

Server. Ideally, it could have an older server version Operating System running, such as Windows

Server 2008 R2. Note that having a local machine withWindows 7, 8.1, or 10 as aMIP workstation will

not cause any problems.

System Requirements
You shouldmeet or exceed theMIP Fund Accounting system requirements before you install the

application.

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile

must be installed on the server and each workstation prior to installingMIP v2019.3.0.

Before You Begin

For optimum results, perform the following tasks on the workstation and server before running the

installation program:

1. Verify that your current environment meets the new system requirements.

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile

must be installed on the server and each workstation prior to installingMIP v2019.3.0.

http://www.abila.com/nonprofit-software/fund-accounting/mip-fund-accounting/system-requirements/
http://www.abila.com/nonprofit-software/fund-accounting/mip-fund-accounting/system-requirements/


Before You Begin

Important! Before installing or upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, theMIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

2. Shut down all applications that are currently running, and restart the computer.

3. AfterWindows has restarted, shut down any applications that have opened at start-up and turn off the

User Account Controls. Additionally, youmay need to disable some applications, such as Norton

AntiVirus©.

Press CTRL-ALT-DELETE to open theWindows Security form. Click the Task Manager button to

open theWindows Task Manager form. On the Applications tab, select each program listed in the

form, and click End Task.

Note: The above processes only shut down the applications for the purposes of the installation. The

next time the computer is rebooted, the programs and all Windows services are restored.

4. If theWindows Firewall is turned on, youmust configure exceptions in the firewall for SQL Server or the

client computer(s) will not be able to connect. For specific instructions on setting up the exceptions, see

article 5156 in the Knowledgebase.

Note: Windows Firewall is turned on by default withWindows 2008 R2 Server and is set to block

remote connections.

5. Delete all files in the local TEMP directory, such as C:\Documents and Settings\<Current User>\Local

Settings\Temp. Since the computer has just rebooted and any unnecessary applications are closed,

there should be few files in the Temp directory. Nevertheless, delete any files or folders that remain

there.

6. If you are runningMIP on a laptop, set your hibernation settings to Never (Start>Settings>Control

Panel>Power Options>Power Schemes tab). Otherwise, when the computer times out, your seat will

become inactive.

7. Before you begin the server install:

The user logged on to the server machinemust be amember of the Local Administrators group and a

user with Administrator rights on the SQL Server or have access to the SQL Server System Admin

(SA) password.

MIP Fund Accounting
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Youmust haveMicrosoft .NET Framework 4.5.2 installed. You can verify your .NET version using

Control Panel>Programs and Features. For specific instructions on installing this version of

Microsoft.NET Framework, see article 7416 in the Knowledgebase.

Important! If the .NET framework is not installed, theMIP Fund Accounting installation wizard

cannot continue. Youmust exit the wizard and restart it after you install the .NET framework version

4.8.0, Full Profile.

To install or upgradeMIP on a virtual environment, youmust use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

For specific instructions for SQL Server 2012 Standard Edition configuration, see article 3156 in the

Knowledgebase. It details how to check an existing instance of SQL Server 2012 Standard Edition

to ensure proper functionality before installingMIP.

SQL Server 2014, SQL Server 2012, SQL Server 2008 R2, Windows 10, 8.1, and 7 Users:

Be sure to start the SQL Server Browser and consider setting the Start Mode to Automatic to ensure

that the workstation can access theMIP system database.

Access the email sent to you by MIP which contains the link and download theMIP software to the

computer functioning as theMIP Fund Accounting Server.

8. Before you begin the workstation install, youmust ensure the following:

The user logged on to the server machinemust be amember of the Local Administrators group.

Each workstation has at the very least read-write access to the “ProgramData” folder--<local drive

letter:>\ProgramData. Also verify that each user that uses Aatrix® (for 1099s, W-2s, 990s, 1095s,

etc.) has rights.

MIP cannot install successfully without these folders and rights.

9. Before you begin the Alerts Setup install, verify that the following are installed:

Internet Information Server (IIS) 7.5must be installed on the web server. TheMIP Fund Accounting

Alerts installation will attempt to install IIS if it is not already installed.

10. Close any open windows.

After performing these steps, you are ready to run the Installation program.
TheGetting Started guide assists in setting up the chart of accounts once the system is successfully

installed, and Help is always available at the click of a button in the context-sensitive online help system.

http://kb.abila.com/node/7416
http://kb.abila.com/node/7416
http://kb.abila.com/node/3156
http://kb.abila.com/node/3156


Chapter 2: New User - Server Install

This chapter describes the installation process for a stand-alone, virtual, or network server. Youmust select

a database engine prior to installing theMIP Fund Accounting Server. Once you have completed these

steps, follow the instructions in New User -Workstation Install to install the workstation.

This chapter explains the following:

"Server Install Overview" (page 27)

"Local Server Configuration" (page 6)

"Directory Structure Overview" (page 28)

"SQL Server (Express Download)" (page 9)

"MIP Fund Accounting Server Install" (page 10)

"Granting Access to theMIP Share Directory" (page 15)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- DownloadMicrosoft SQL Server 2014 Express with Advanced Services from the

SQL Server Express Installation link on the Setup tab of theMIP Fund Accounting Install on theMIP

Fund Accounting AutoRun.exe or use an already installed version of Microsoft SQL Server 2008 R2

Express Edition with Advanced Services, SQL Server 2008 R2 (Full Version), SQL Server 2012 (Full

Version), or SQL Server 2014 (Full Version).

MIP Fund Accounting Server - TheMIP Fund Accounting Server installation creates theMIP Share

directory. We recommend accepting the default path when installing the server component.

The necessary files related to theMIP Fund Accounting Server Install are copied to the SQL server. To

download theMicrosoft SQL Server 2014 Express Edition with Advanced Services from theMicrosoft

website, click the SQL Server Express Installation link that displays on the Setup tab of theMIP Fund

Accounting Install on theMIP Fund Accounting AutoRun.exe.

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile must

be installed on the server and each workstation prior to installingMIP v2019.3.0.
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Important! Before installing the software, verify that you are a user with Administrator rights on the SQL

Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not be able

to install the software.

Local Server Configuration
In order to successfully install and runMIP on a stand-alonemachine, verify that the File and Printer

Sharing Service is installed, the TCP/IP protocol is installed, and the Server Service is enabled. Then, you

need to complete the instructions in this chapter to ensure that theMIP Fund Accounting Server is installed

correctly. Once you have completed these steps, follow the instructions in New User -Workstation Install

to install the workstation.

Note: If you do not have a network adapter driver installed, you cannot continue theMIP install. You need

to install theMicrosoft Loopback Adapter first (follow the instructions below).

To Activate File and Printer Sharing Service:

1. Right-click Network and then select Properties. The Network and Sharing Center displays.

2. Under Sharing and Discovery, verify that File Sharing and Printer sharing are listed as On.

3. If Off displays, expand the down arrow and select the Turn on option.

To Enable the Server Service:

1. Go to Start>Settings>Control Panel>Administrative Tools>Services.

2. Double-click the Server Manager.

3. Expand Configuration, and click Services.

4. Make sure that the Startup type is Automatic and the Server Status is Started. If those settings are

not in place, implement them, and then click OK.

To Install TCP/IP:

1. Right-click Network and then select Properties.

2. Click View Status for Local Area Connection and then click Properties.

3. If Internet Protocol Version 4 or 6 (TCP/IPv4/v6) is not selected in the list, check the box and click the
Install button. If it is listed, click OK and skip to step 6.

4. Select Protocol, and then click Add.



Directory Structure Overview

5. Select Internet Protocol (TCP/IP), and then click OK.

6. Click Close to close the Local Area Connection Status window.

Note: If you are actually using TCP/IP to connect to your network, make sure that it is configured properly.

Directory Structure Overview
TheMIP Fund Accounting Server executable (SETUP.EXE) creates theMIP Share directory. We

recommend accepting the default path when installing the server component.

Data Files and Directory Structure

When installing theMIP Fund Accounting Server, the data files and workstation share files are stored on the

machine that is functioning as the server. The workstation installation stores theMIP system and program

files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory that was

specified during installation.

MIP Fund Accounting

Installation Guide
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MIP Share Directory

Note: Do not Password Protect theMIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the

Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.

DATA contains a copy of the NPSSQLSYS.NPS and NTO.NPS files. These are the system and sample

database files that comewith the system.

DDEPOSIT contains ACH.TXT, which will be altered when using the Direct Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for A/P

module.

FORMATS contain the files needed to print custom forms in the system. This is where you should store

custom formats created by the Forms Designer module.

GRANTADMIN contains scanned images of sample grant documentation for the Grant Administration

module.

IMPORT includes sample DEF and data files that can be used with the Data Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files

that document when an error occurs related to the Alerts module, such as, failure to connect to the Alert

Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not actually

created until the attachments feature is activated in the system (Organization>Attachments>Set Up

Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run theMIP Fund AccountingWorkstation installation. Each of

the client machines will need to access this folder in order to install theWorkstation component. The

SETUP.EXE file launches theMIP Fund AccountingWorkstation installation.



SQL Server (Express Download)

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server (Express Download)
Select one of the following that best describes your current setup, and then follow the instructions below for

installation:

SQL Server Express (can be downloaded by following a link) - Microsoft SQL Server 2014 Express

Edition with Advanced Services can be downloaded from the SQL Server Express Installation link on your
MIP Fund Accounting Version 2020.x Setup tab.

SQL 2014, SQL 2012, SQL 2008 R2, SQL Express (Already installed) - Either theMicrosoft SQL

Server or SQL Express has already been installed as your server using theMicrosoft website at

www.microsoft.com. Or SQL Server 2008 R2, 2012, or 2014 has already been installed as your server.

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this directory is

located on the local drive in which your operating system is installed. Use the browser to change this

destination during the installation.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the

ability to administer it according to your practices.

SQL Server Express (Can be downloaded by following a link)

This section describes the installation process for theMicrosoft SQL Server 2016 Express Edition with

Advanced Services from theMIP Fund Accounting Version 2020.x Setup Tab. Please carefully read each

panel of the wizard during installation.

Important! Before you begin, verify that Microsoft .NET Framework 4.8.0 Full Profile or higher is

installed before you try to Install MIP Fund Accounting Server. Go to Start>Settings>Control

Panel>Programs and Features.

1. Download theMIP software to the computer functioning as theMIP Fund Accounting Server. To get the

latest download, see the Knowledgebase.

Once complete, the system automatically launches autorun.exe and the Abila MIP Fund Accounting

Setup window displays.

MIP Fund Accounting
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2. Select SQL Server Express Installation and follow the steps to download SQL Server Express from the

Microsoft website. Upon completion, be sure to install the SQL Server's latest service pack updates

before continuing the installation process.

Note: Click the Here link to open a browser to access instructions for installing the SQL Server 2016
Express on the Knowledgebase.

MIP Fund Accounting Server Install
When installing theMIP Fund Accounting Server, a directory is created by default—<Server Name>:\MIP

SHARE. TheMIP Fund Accounting Server must be installed before proceeding to the "MIP Fund

AccountingWorkstation Install" (page 18).

Note: To install or upgrade in a virtual environment, youmust use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

Please carefully read each panel of the wizard during installation.



MIP Fund Accounting Server Install

1. Be sure you are logged in as a user who has local administrator rights to perform the install. Also, verify

that you are a user with Administrator rights on the SQL Server or have access to the SQL Server

System Admin (SA) password. (If you are not an Administrator on the SQL Server nor have the SA

password, you will not be able to install the software.)

2. If you have not already done so, download theMIP software to the computer functioning as theMIP Fund

Accounting Server.

The system automatically launches autorun.exe and the Abila MIP Fund Accounting Setup window

displays.

3. After reviewing the provided documentation, select the Begin Installation Process option. The system

begins extracting the setup.exe file.

4. The Abila MIP Fund Accounting Server InstallShieldWizard prepares to install. TheWelcome panel

displays. Click Next.

MIP Fund Accounting
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Server Installation.

6. Click Next. The system displays the Product Registration panel. Enter the Serial Number and

Activation Code.

The activation code is case sensitive, so it must be entered exactly as it appears on the notification

included with the system. (Store the activation code in a safe place in case your system needs to

be reinstalled.)



MIP Fund Accounting Server Install

Activation

Codes

The activation code is determined by the system’s license. The system uses the

activation code to determine whichmodules you own, how many additional databases

you have purchased, and how many concurrent users you will have available. Later, if

you decide to add amodule or increase your users or databases, you need to enter a

new activation code. To enter a new license, with Administrative user rights open the

System>Activate License form. To add amodule to an existing database, use the

Organization>Add A Module form.

7. Click Next. Accept the default MIP Share destination folder (recommended), or use the Change button to

navigate to a different location.

MIP Fund Accounting
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8. Click Next. Select the database server that you are installing to by using the drop-down arrow, or

Browse to the database location.

Then, select how you want to connect to this server. If Server authentication is chosen, enter the Login

ID and Password.

9. Click Next. You are now ready to Install MIP Fund Accounting.

10. Click Install to begin, or use the Back button tomake changes.

11. Proceed through theMIP Server setup. This process may take several minutes.

12. When the installation is complete, the InstallShieldWizard Completed panel displays.



Granting Access to the MIP Share Directory

This is the final panel of the server installation. It verifies that theMIP Fund Accounting Server installed

successfully.

Select the “Install Abila MIP Workstation” check box, and then click Finish to continue through the

installation program by launching theMIP Fund AccountingWorkstation Installation wizard. For

instructions, proceed to New User -Workstation Install.

Alternatively, if you do not select the check box, you can install later from theMIP Share directory. For

more information, see "Granting Access to theMIP Share Directory" (page 15).

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts IIS Install" (page 43)

13. Click Finish to complete the install.

14. If applicable, click the Exit button on theMIP Fund Accounting Installation Startup form.

15. Navigate to theMIP Share directory on the Server and set it to share with Full control permissions to

Everyone.

Granting Access to the MIP Share Directory
TheMIP Share directory (which the Server installation created) contains the files necessary to install MIP's

program files at each workstation. First, theMIP Share directory must be shared so that the workstations will

have access to it.

1. Right-click theMIP Share directory at the server and select Share. . . If you do not see Shared, you will

need to log on as a user account that is amember of the Local Administrators or Power Users group.

2. On the Sharing tab, click Advanced Sharing. And then select the Share this folder check box.

MIP Fund Accounting
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3. Click the Permissions button.

4. Add the desired users/groups.

Note: If you share to specific users/groups and not the “Everyone” group, you will need to add the

“System” account with full rights on the Security tab. If you give the “Everyone” group full rights, then

it is not necessary to add “System.”

5. Grant each user/group Full Control and click OK. A minimum of Change and Read permissions are

required. NTFS formatted servers will display a Security tab, in which case youmust grant NTFS

Permissions. You need to allow System with Full Control. The Security tab will not be available if the

drive is formatted using FAT32.

6. Click OK to close the Advanced Sharing window.

7. Click the Security tab.

8. Add the desired users/groups. Typically, the default NTFS permission is all you will need. However,

you can grant the users/groups Full Control access.

9. Click OK to apply these settings.

10. Click Close to close theMIP Share Properties window.

Note: Youmust allow inheritable permissions.



Chapter 3: New User - Workstation Install

Before starting the Workstation installation, you must have already completed the "MIP Fund

Accounting Server Install" (page 10) and "Granting Access to the MIP Share Directory" (page 15), if

there is a network.

This chapter describes the installation process for theMIP Fund AccountingWorkstation. This installation

provides the program files needed to run the system. During the installation, you can choose which shortcut

and executable files to install for each system, such as Administration, Accounting, Payroll, or the entire

system. Please carefully read each panel of the wizard during installation.

The necessary files related to this installation are copied to theMIP Share directory of the server during the

MIP Fund Accounting Server installation. There is only one executable (SETUP.EXE) for the workstation

install.

Note: The user logged on to the workstationmachinemust be amember of the Local Administrators

group.

Ensuring Access to “All Users” Folder
Before you begin the workstation install and you are using Aatrix®, youmust ensure that the workstation

has access to the “All Users” directory. The following steps should be completed for each workstation

running onWindows 7.

1. Click Start>Run.

2. Enter the <local drive letter:> in the Open box.

3. Click OK. The system displays an explore window.

4. Open the Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses

Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on folder>Properties>Security

tab). MIP Fund Accounting cannot install successfully without these folders and rights. These steps

should be completed for each workstation running onWindows 7, 8.1, or 10.

MIP Fund Accounting
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Data Files and Directory Structure
When installing theMIP Fund AccountingWorkstation, the system and program files are stored on each

computer. After the workstation installation, the following directory structure exists on the drive and in the

directory that was specified during installation.

MIP Directory

TheMIP Fund AccountingWorkstation installation creates aMIP directory on the local disk partition with

themost space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are

included in the PROGS directory. Do NOT delete any of these files.

MIP Fund Accounting Workstation Install
This section describes the workstation install. There are two ways to access this install:

If you selected the Install Abila MIP Workstation check box at the end of the Server Install, the system

automatically launches theWelcome panel of theMIP Fund AccountingWorkstation install.

If you are installing the workstation only, go to the workstationmachine and log on as a user with local

administrator rights. Navigate to theMIP Share directory (\\MIP Share) on the Server, open the Setup

sub directory, and select Setup.exe.



MIP Fund Accounting Workstation Install

1. The Abila MIP Fund AccountingWorkstation install Welcome panel displays.

2. Click Next. Review the End User License Agreement and select the “I accept the terms in the license

agreement” option.

3. Click Next. Accept the default MIP destination folder (recommended), or use the Change button to

navigate to a different location.

MIP Fund Accounting
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4. Click Next. The Custom Setup panel displays, which allows you to select the systems you would like

to install. By default, the system installs the start menu shortcuts and program files for all systems,

even if they are not part of the license.

To prevent a system from being installed, ensure that the “X” (Entire feature will be unavailable) is

selected. This designation prevents the installation of the program files and the start menu shortcuts for

that system. Youmay find this useful when you need to restrict a user from launching a specific

system.



MIP Fund Accounting Workstation Install

Note: If you do not install all systems now, but later decide you want to install the program files or start

menu shortcuts, you can do so using Start>Settings>Control Panel>Add or Remove Programs. Select

Abila MIP Workstation and the Change button. The system displays theWelcome panel of the Install

wizard. Click Next. Then, on the ProgramMaintenance panel, select theModify option button, followed

by the Next button.

5. Click Next. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back tomake changes to your installation settings.

7. Proceed through theMIP Fund AccountingWorkstation setup. This process may take several minutes.

The InstallShieldWizard Completed panel displays.

MIP Fund Accounting
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8. Click Continue to complete theWorkstation Install.

9. Additional installs launch after you click Continue to complete theWorkstation Install. Allow any

additional installs to complete, and then click OK on the “Your install completed successfully” window

message.

10. This is the final window of the workstation installation. It verifies that theMIP Fund Accounting

Workstation installed successfully.

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts IIS Install" (page

43)

If applicable, click the Exit button on theMIP Fund Accounting Installation Setup form.

At the end of theWorkstation install, reboot your computer only if prompted to do so.

Note: Remember, a workstation installationmust be performed on each workstation that needs to run

MIP Fund Accounting.



Chapter 4: Existing User - Upgrading

This chapter provides information that only existing users might need. It explains:

"Upgrading from a Previous Version" (page 23)

"Changing Your Database Engine" (page 24)

"Updating Your Organization Database to Version 2020.x" (page 24)

"Activating Your License" (page 24)

"Adding aModule to anOrganization" (page 25)

"Setting Up Security" (page 26)

Upgrading from a Previous Version
You can only upgrade your program files to version 2019.x from versions 2018.x through 2016.2. If you are

not currently running one of these versions, youmust upgrade to one of them before you can upgrade the

application files to 2019.x.

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile must

be installed on the server and each workstation prior to installingMIP v2019.3.0.

Important! Before upgrading to the current software version, verify that you are a user with Administrator

rights on the SQL Server or have access to the SQL Server System Admin (SA) password. Upon

upgrade, theMIP software will be uninstalled. If you are not an Administrator on the SQL Server nor have

the SA password, you will not be able to install any version of the software.

1. Follow the instructions in Existing User - Server Install to upgrade the organizational database on a

server from a previous version.

2. Once you have installed theMIP Fund Accounting Server, you will need to install the workstation.

Open the setup.exe from the \\MIP Share\Setup directory on your server, to launch the "MIP Fund

AccountingWorkstation Install" (page 37).

If theMIP Fund AccountingWorkstation component is already installed on the server or you wish to

install theWorkstation on the server for the first time, you will need to open the application on the

server to complete the upgrade process before proceeding to the next step.
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3. Follow the instructions in Existing User -Workstation Install, to upgrade each user’s workstation.

4. Finally, follow the instructions to complete the Alerts installation on your IIS Web Server.

Changing Your Database Engine
If you are upgrading andmoving your database to a different instance of SQL Express or SQL Server, back

up your system and organization databases, and then uninstall MIP and your current instance of SQL.

After you complete the installation process, restore your system database, NPSSQLSYS, along with your

organization database. For specific instructions on uninstalling, see "UninstallingMIP Fund Accounting"

(page 51) and see "Supplemental Maintenance" (page 54) for instructions on backing up and restoring a

database.

For specific instructions onmoving theMIP Fund Accounting Server to a new server/computer, see article

876 in the Knowledgebase.

Updating Your Organization Database to Version 2020.x
You can only update your organization database after the server and workstation have been upgraded to

version 2020.x. To do so:

1. Log on to any system (Start>Programs>Abila>MIP Fund Accounting), and select an Organization.

2. The system displays amessage stating that the organization databasemust be updated to the current

version.

Select Yes, to begin the backup process to back up your organization database and then upgrade it.
This is strongly recommended.

Select No, if you have a current backup of the database and want to begin the update process
immediately.

3. A utility program runs. Click Finish.

4. When complete, amessage displays informing you that your database has been updated successfully.

5. Click OK.

Activating Your License
When you initially purchase the system, an activation code that activates any and all modules that have

been purchased is included with the software. You are prompted to enter that code during installation, and

http://kb.abila.com/node/876
http://kb.abila.com/node/876
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do not need to enter it any other time. However, if you are currently using the system and decide to add a

module (or add users or databases), a new activation code will be sent to you.

Enter the new code in the system in order to use the new features:

1. Open the System>Activate License form.

2. On theOwned tab (or Evaluation tab if evaluating a new module), enter the new activation code. Note

that the activation code is case sensitive, so it must be entered exactly as it appears on the notification.

3. Click OK, and then the new features are registered in the system.

4. Exit the system (File>Exit), and then reopen it.

Note: If you were evaluating or adding the Scheduler module, and you did not include the program files and

start menu shortcut, you can do so now. Click Start>Settings>Control Panel>Add or Remove Programs.

Select MIP Fund AccountingWorkstation and the Change button. The system displays theWelcome panel

of the Install wizard. Click Next. Then, on the ProgramMaintenance panel, select theModify option button,

followed by the Next button.

Adding a Module to an Organization
A module can be added to the current organization, but first ensure that there are no users currently logged on

to the system.

Note: The activation codemust be changed (MIP Fund Accounting>System>Activate License) to include

Scheduler, Electronic Requisitions, and Payroll modules before thesemodules can be added.

To add a module:

1. Open theMIP Fund Accounting>System>Current Activity form to ensure that no one (except yourself)

is currently using the organization being updated.

2. Open the organization (File>Open Organization) in which to add themodule.

3. Open theOrganization>Add a Module wizard. On the first panel, select themodule to add by selecting

the appropriate check box.

4. Follow the instructions on the screen and continue through the wizard.

5. Click Finish, and then the system adds the designatedmodule to the current organization. This process

may take several minutes.

6. To add amodule to another organization, repeat this process.
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Note: For more information about the Add aModule wizard, see the online help or the Administration
guide.

Setting Up Security
User security needs to be set up for each new module. To do so:

1. Open the Security>Set Up Organization Menus form to grant rights to users. This includes granting

rights to new menu selections that are part of the new module.

2. Remember, this process must be repeated for each separate organization in which themodule was

added and requires exclusive access to the system database.

Note: For more information about the Set UpOrganizationMenus form, see the online help or the

Administration guide.



Chapter 5: Existing User - Server Install

This chapter describes the installation process for a stand-alone or network server. Prior to upgrading the

MIP Fund Accounting Server Install, youmust close all workstations. Once you have completed the steps

in this chapter, follow the instructions in Existing User -Workstation Install to install the workstation.

This chapter explains the following:

"Server Install Overview" (page 27)

"Directory Structure Overview" (page 28)

"SQL Server Install " (page 29)

"MIP Fund Accounting Server Install" (page 31)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- DownloadMicrosoft SQL Server 2014 Express with Advanced Services from the

SQL Server Express Installation link on the Setup tab of theMIP Fund Accounting Install on theMIP

Fund Accounting AutoRun.exe or use an already installed version of Microsoft SQL Server 2008 R2

Express Edition with Advanced Services, SQL Server 2008 R2 (Full Version), SQL Server 2012 (Full

Version), or SQL Server 2014 (Full Version).

MIP Fund Accounting Server - TheMIP Fund Accounting Server installation creates theMIP Share

directory. We recommend accepting the default path when installing the server component.

The necessary files related to theMIP Fund Accounting Server Install are copied to the SQL server. To

download theMicrosoft SQL Server 2014 Express Edition with Advanced Services from theMicrosoft

website, click the SQL Server Express Installation link that displays on the Setup tab of theMIP Fund

Accounting Install on theMIP Fund Accounting AutoRun.exe.

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile must

be installed on the server and each workstation prior to installingMIP v2019.3.0.

Important! Before installing the software, verify that you are a user with Administrator rights on the SQL

Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not be able

to install the software.
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Directory Structure Overview
TheMIP Fund Accounting Server executable (SETUP.EXE) creates theMIP Share directory. We

recommend accepting the default path when installing the server component.

Data Files and Directory Structure

When installing theMIP Fund Accounting Server, the data files and workstation share files are stored on

themachine that is functioning as the server. The workstation installation stores theMIP system and

program files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory that

was specified during installation.

MIP Share Directory

Note: Do not Password Protect theMIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the

Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.



SQL Server Install

DATA contains a copy of the NPSSQLSYS.NPS and NTO.NPS files. These are the system and sample

database files that comewith the system.

DDEPOSIT contains ACH.TXT, which will be altered when using the Direct Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for A/P

module.

FORMATS contain the files needed to print custom forms in the system. This is where you should store

custom formats created by the Forms Designer module.

GRANTADMIN contains scanned images of sample grant documentation for the Grant Administration

module.

IMPORT includes sample DEF and data files that can be used with the Data Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files

that document when an error occurs related to the Alerts module, such as, failure to connect to the Alert

Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not actually

created until the attachments feature is activated in the system (Organization>Attachments>Set Up

Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run theMIP Fund AccountingWorkstation installation. Each of the

client machines will need to access this folder in order to install theWorkstation component. The

SETUP.EXE file launches theMIP Fund AccountingWorkstation installation.

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server Install

Important! Our System Requirements have changed; Microsoft .NET Framework 4.8.0, Full Profile must

be installed on the server and each workstation prior to installingMIP v2019.3.0.

Select one of the following that best describes your current setup, and then follow the instructions below for

installation:
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SQL Server Express (can be downloaded by following a link on the AutoRun.exe) - Microsoft SQL

Server 2014 Express Edition with Advanced Services can be downloaded from the SQL Server Express
Installation link on theMIP AutoRun.exe.

SQL 2014, SQL 2012, SQL 2008 R2, SQL Express (Already installed) - Either theMicrosoft SQL

Server or SQL Express have already been installed as your server using theMicrosoft website at

www.microsoft.com. Or, SQL Server 2008 R2, 2012, 2014 has already been installed as your server.

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this directory

is located on the local drive in which your operating system is installed. Use the browser to change this

destination during the installation.

Important! Before installing the software, verify that you are a user with Administrator rights on the SQL

Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not be able

to install the software.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the

ability to administer it according to your practices.

SQL Server (Express Downloaded)

This section describes the download process for theMicrosoft SQL Server 2014 Express Edition with

Advanced Services from theMIP AutoRun.exe. Please carefully read each panel of the wizard during

installation.

Important! Before you begin, verify that Microsoft .NET Framework 4.8.0 Full Profile or higher is

installed before you try to Install MIP Server. Go to Start>Settings>Control Panel> Programs and

Features.

1. On the computer functioning as theMIP Server, log on as a user with local administrator rights.

Note: With the release of version 2016.2, the Auto Update program was discontinued and was

uninstalled during that MIP installation process.

2. Download and extract the latest MIP software updates to the computer functioning as theMIP MIP

Server. To get the latest download, see the Knowledgebase.

Important! Before upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, theMIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

http://www.microsoft.com/
http://www.abila.com/support
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Once the download is complete, the system automatically launches autorun.exe and theMIP Setup

window displays.

3. Select SQL Server Express Installation and follow the steps to download SQL Server Express from the

Microsoft website. Upon completion, be sure to install the SQL Server's latest service pack updates

before continuing the installation process.

Note: Click the Here link to open a browser to access instructions for installing the SQL Server 2014 -
SP1 Express on the Knowledgebase.

MIP Fund Accounting Server Install
This section describes the install process by continuing to use your existing database server.

TheMIP Server must be upgraded before proceeding to the "Existing User -Workstation Install" (page 36). It

is very important to perform a backup of your database before performing the upgrade.

Please carefully read each panel of the wizard during installation.

Note: To install or upgrade in a virtual environment, youmust use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.
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1. On the computer functioning as theMIP Server and log on as a user with local administrator rights.

Important! Before upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, theMIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

2. If you have not already done so, download and extract the latest MIP Fund Accounting software to the

computer functioning as theMIP Server. To get the latest download, see the Knowledgebase.

3. Once complete, the system automatically launches autorun.exe and theMIP Fund Accounting Setup

window displays. After reviewing the provided documentation, select the Begin Installation Process

option.

The system begins extracting the setup.exe file.

4. The Abila MIP Fund Accounting Server InstallShieldWizard prepares to install. TheWelcome panel

displays. Click Next.

http://www.abila.com/support
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Server Installation.

6. Click Next. You are now ready to Install MIP Fund Accounting.

7. Click Install to begin, or use the Back button tomake changes.
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8. The system begins upgrading theMIP Fund Accounting Server software. This process may take

several minutes.

9. When the upgrade is complete, the InstallShieldWizard Completed panel displays.

This is the final panel of the server installation. It verifies that theMIP Fund Accounting Server installed

successfully.

Select the “Install Abila MIP Workstation” check box, and then click Finish to continue through the

installation program by launching theMIP Fund AccountingWorkstation Installation wizard. For

instructions, proceed to "Existing User -Workstation Install" (page 36).



MIP Fund Accounting Server Install

Alternatively, if you do not select the check box, you can install later from theMIP Share directory. For

more information, see "Granting Access to theMIP Share Directory" (page 15).

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts IIS Install" (page 43)

10. Click Finish to complete the install.

11. If applicable, click the Exit button on theMIP Fund Accounting Installation Startup form.

12. Navigate to theMIP Share directory on the Server and set it to share with Full control permissions to

Everyone.

Note: Reboot your computer only if prompted to do so.
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Before starting the Workstation Installation, you must have already completed the MIP Fund

Accounting Server Install and Granting Access to the MIP Share Directory, if there is a network.

This chapter describes the installation process for theMIP Fund AccountingWorkstation. This installation

provides the program files needed to run the system. During the installation, theMIP Fund Accounting

shortcut and executable files install and you can choose for each system, such as Scheduler or the entire

system. Please carefully read each panel of the wizard during installation.

The necessary files related to this installation are copied to theMIP Share directory of the server during the

MIP Fund Accounting Server installation. There is only one executable (SETUP.EXE) for the workstation

install.

Note: The user logged on to the workstationmachinemust be amember of the Local Administrators

group.

Ensuring Access to “All Users” Folder
Before you begin the workstation install and you are using Aatrix®, youmust ensure that the workstation

has access to the “All Users” directory. The following steps should be completed for each workstation

running onWindows 7.

1. Click Start>Run.

2. Enter the <local drive letter:> in the Open box.

3. Click OK. The system displays an explore window.

4. Open the Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses

Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on folder>Properties>Security

tab). MIP Fund Accounting cannot install successfully without these folders and rights. These steps

should be completed for each workstation running onWindows 7, 8.1, or 10.

Data Files and Directory Structure
When installing theMIP Fund AccountingWorkstation, the system and program files are stored on each

computer. After the workstation installation, the following directory structure exists on the drive and in the
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directory that was specified during installation.

MIP Directory

TheMIP Fund AccountingWorkstation installation creates aMIP directory on the local disk partition with

themost space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are

included in the PROGS directory. Do NOT delete any of these files.

MIP Fund Accounting Workstation Install
TheMIP Fund Accounting Server must be upgraded prior to upgrading the MIP Fund Accounting

Workstation.

If you selected the Install MIP Fund AccountingWorkstation check box at the end of the Server Install, the

system automatically launches theWelcome panel of theMIP Fund AccountingWorkstation install.

When the existing data engine configuration is kept on each workstation, select

Start>Programs>MIP>MIP>{any application}. The system displays amessage indicating a new version

is required; select Yes to automatically launch theMIP Fund AccountingWorkstation Installation.
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If the auto launch fails, due to the data engine configuration changing orWindows OS users with User

Account Control turned on, follow the steps below to launch theMIP Fund AccountingWorkstation Install.

Note: Youmust access \MIP SHARE using a UNC Path, not amapped drive. Mapped drives are okay as

long as they are consistent and persistent across all workstations, such as everyone having aG:\drive

mapped toMIP Share.

Click Start>Run.

Enter the <\\server name> in the Open box.

Click OK. The system displays an explore window with all the shared folders listed.

Open theMIP Share directory on the server.

Open the Setup folder and run SETUP.EXE.

Important!Windows OS Users - If the User Account Control is turned on, amessage displays that “A

program needs your permission to continue,” click Continue to proceed.

The system automatically launches theWelcome panel of theMIP Fund AccountingWorkstation install, if

you selected the Install MIP Fund AccountingWorkstation check box at the end of the Server Install or

opened an application after the Server was updated.

If you are installing the workstation only, go to the workstationmachine and log on as a user with local

administrator rights. Navigate to theMIP Share directory (\\MIP Share) on the Server, open the Setup sub

directory, and select Setup.exe.
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1. The Abila MIP Fund AccountingWorkstation InstallShieldWelcome panel displays.

2. Click Next. Review the End User License Agreement and select the “I accept the terms in the license

agreement” option.

3. Click Next. Accept the default MIP destination folder (recommended), or use the Change button to

navigate to a different location.



MIP Fund Accounting Workstation Install

4. Click Next. The Custom Setup panel displays, which allows you to select the systems you would like to

install.

The Scheduler system is not merged intoMIP Fund Accounting because it is an application used to

monitor scheduler activities. To prevent the Scheduler system from being installed, ensure that the “X”

(Entire feature will be unavailable) is selected. This designation prevents the installation of the program

files and the start menu shortcut for that system. Youmay find this useful when you need to restrict a

user from launching the Scheduler system.
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Note: If you do not install all systems now, but later decide you want to install the Scheduler program

files or start menu shortcut, you can do so using Start>Settings>Control Panel>Add or Remove

Programs. Select Abila MIP Workstation and the Change button. The system displays theWelcome

panel of the Install wizard. Click Next. Then, on the ProgramMaintenance panel, select theModify

option button, followed by the Next button.

5. Click Next. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back tomake changes to your installation settings.

7. The system begins upgrading theMIP Fund AccountingWorkstation software. This process may take

several minutes. The InstallShieldWizard Completed panel displays.
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8. Click Continue to complete theWorkstation upgrade.

9. Additional installs launch after you click Continue to complete theWorkstation upgrade. Allow any

additional installs to complete, and then click OK on the “Your install completed successfully” form.

10. This is the final window of the workstation installation. It verifies that theMIP Fund Accounting

Workstation installed successfully. If applicable, click the Exit button on theMIP Fund Accounting

Installation Setup form.

Note: At the end of theWorkstation install, reboot your computer only if prompted to do so.

11. If theMIP Fund AccountingWorkstation component is already installed on the server or you have

installed theWorkstation on the server for the first time, you will need to open the application on the

server to complete the upgrade process, which allows the system to automatically update this

component.

Note: If theMIP Fund AccountingWorkstation component is not installed on the server, a workstation

installationmust be performed on each workstation that needs to runMIP Fund Accounting.

12. Open theOrganization>Add a Module wizard. Run through this wizard to add any new modules.

13. Open the Security>Set Up Organization Menus form to grant rights to new menu selections that are

part of any new modules that were added.

14. Optional, install Alerts on your IIS Web Server. For more information, see "Alerts IIS Install" (page 43)
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This chapter includes specific instructions on how to install theMIP Fund Accounting Alerts on a web

server.

Download MIP Fund Accounting
1. To downloadMIP Fund Accounting, click the link in the email received from your MIP sales

representative to open theMIP Fund Accounting download page. To install Version 2020.x, select the

appropriate download link.

2. The system automatically runs SETUP.EXE. The Abila MIP Fund Accounting installationmenu

displays the Setup tab.

3. Review the following documents: Quick Start, Installation Guide, and System Requirements. You can
print these documents or review them online.
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Begin Installation Process

Before you begin, you must ensure the following:

The user logged on the server machinemust be amember of the Local Administrators group, as well as

an Administrator on the database server.

Verify that Microsoft .NET Framework of 4.5.2 Full or higher and Internet Information Services (IIS) 7.5

or higher are installed.

Verify that you haveMIP Fund Accounting installed and have accessed the system at least once.

Confirm the location and access to theMIP Fund Accounting database server.

Caution! If IIS Web Server is on amachine using aWindows 7, 8.1, or 10 Operating System, the

system has a 10 concurrent connection limitation. This is a knownMicrosoft restriction when using

Windows 7, 8.1. or 10 as the Alerts Server. It is recommended that you use a separate server on your

network as your IIS Web Server. Note that, having a local machine withWindows 7, 8.1, or 10 as aMIP

workstation, will not cause any problems.

Important! If the IIS Web Server is installed on the same computer along with theMIP programs and

database, you could experience connection limitations and possible performance delays when

processing transactions and running reports.
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MIP Fund Accounting Alerts Server Install

Complete the following steps to install MIP Fund Accounting Alerts on the web server.

1. After reviewing the provided documentation, select the Setup Alerts tab.

2. Select the Begin Alerts Installation Process option. The system begins extracting the setup.exe file.

3. The system verifies theMicrosoft .NET Framework and Internet Information Services (IIS) versions. If

your web server does not have the latest versions, theMIP Fund Accounting Alerts installation wizard

cannot continue. Youmust exit the wizard and restart it after you install the .NET Framework version

4.5.2 and/or IIS version 7.5.

Note: If IIS or .NET is updated to a newer version, youmight be prompted to restart your server.

Important! If the User Account Control is not turned off, click Yes to allow the changes to the

computer.

4. The Abila MIP Fund Accounting Alerts IIS InstallShieldWizard prepares to install. TheWelcome panel

displays. Click Next.
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Alerts IIS Installation.

6. Click Next. Select the database server that you are installing to by using the drop-down arrow, or

Browse to the database location.

Then, select how you want to connect to this server. If Server authentication is chose, enter the Login

ID and Password.



MIP Fund Accounting Alerts Server Install

7. Click Next. You are now ready to Install MIP Fund Accounting Alerts IIS.

8. Click Install to begin, or use the Back button tomake changes.

9. During the installation process, a progress bar displays, as well as several windows will open and close.

This process may take several minutes to complete.

10. When the installation is complete, the InstallShieldWizard Completed panel displays.
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11. Click Finish to complete the install.

12. If applicable, click the Exit button on theMIP Fund Accounting Installation Startup form.

Before you begin creating Real-time Alert notices, you will need tomake sure everything is setup in

Administration. For more information about setting up Alerts, see How Do I Set Up Alerts? and for steps
to create themany different Alert notifications, see How Do I Create an Alert? These are available as
checklists for Administration in theMIP Fund Accounting system's Online Help (Help>Checklists).

Setting Up Alerts
Complete these steps in the following order to be begin creating Real-time Alert notices:

1. Complete the Optional Alerts Install:

On the server functioning as your network's web server,

The user logged on the server machinemust be amember of the Local Administrators group, as

well as an Administrator on the database server.

Verify that Microsoft .NET Framework of 4.5.2 Full or higher and Internet Information Services

(IIS) 7.5 or higher are installed.

Confirm the location and access to theMIP Fund Accounting database server.

Download and extract theMIP Fund Accounting installation, select the Setup Alerts tab, and

complete the Alerts Installation process. To get the latest download, see the Knowledgebase.

http://www.abila.com/support
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Caution! If IIS Web Server is on amachine using aWindows 7, 8.1, or 10 Operating System, the

system has a 10 concurrent connection limitation. This is a knownMicrosoft restriction when using

Windows 7, 8.1, or 10 as the Alerts Server. It is recommended that you use a separate server on your

network as your IIS Web Server. Note that having a local machine withWindows 7, 8.1, or 10 as a

MIP workstation will not cause any problems.

Important! If the IIS Web Server is installed on the same computer along with theMIP programs and

database, you could experience connection limitations and possible performance delays when

processing transactions and running reports.

2. Review the Setting Up Your Organization checklist to ensure that the organization is set up properly.

3. As a user with Administration rights, perform the following steps:

a. Ensure all of your users have email addresses and have been added to the organization using the

Security>Maintain Users form.

b. Ensure that the SMTP Email is set up and configured using the following steps:

i. Enter the Set Up SMTP Connection information using the Organization>Organization

Information>SMTP Email tab. (To view examples of how to set up your SMTP connection, see

Configuring SMTP.)

ii. Enter the From and To email addresses to test your connection is set up correctly.

iii. Click the Send Test Email button.

iv. Click Save.

c. Create an Alert and assign users using the Organization>Set Up Alerts form. (To view examples of

how to create an alert, see How Do I Create an Alert? The Administration checklist is available in the

MIP Fund Accounting system's Online Help (Help>Checklists)

d. UseOptions>System Preferences to enter a default From email address for Alerts, However, if the

Use Custom Credentials check box is selected on theOrganization>Organization

Information>SMTP Email tab; the User email address entered theremust be the default From email

address.
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Note: System Users have the ability to turn off the Real-time In-product notifications, by clearing the

Connect to the Alert Server check box on theOptions>User Preferences form. If not selected, the

alerts will continue to collect in theMessage Center and Real-time Email Alert Notices will be sent,

but the number count on theMessage Center will not reflect accurately.



Chapter 8: Uninstalling MIP Fund Accounting

This chapter describes how to uninstall theMIP Fund Accounting system.

Uninstalling Steps
The following components must be uninstalled in this order:

1. MIP Fund AccountingWorkstation

2. MIP Fund Accounting Server

Before uninstalling, make a backup of the organization database; see Supplemental Maintenance for more

information. Uninstall only removes the files that the installation process copied to your computer.

Data Import/Export,

Direct Deposit, EFT

for A/P, and Forms

Designer Users

When installing, the system copies files to the \MIP SHARE\IMPORT,

DDEPOSIT, EPAYAP, and FORMATS directories. During the uninstall process

these files are removed. If changes have beenmade to these files, either change

the names of the files or move them to another directory.

To Remove the MIP Fund Accounting Workstation:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila MIP Workstation, and then click Uninstall.

–OR–

If you are uninstalling aMIP Fund AccountingWorkstation on a computer, which acts as a client only (it is

not on theMIP Fund Accounting Server), run the Uninstall on the Server through a UNC path (<server

name>\MIP Share\Setup\Uninstall).

To Remove the MIP Fund Accounting Server:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila MIP Server, and then click Uninstall.
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To Remove the MIP Fund Accounting System including all Third Party Applications:

1. Use the Uninstall shortcut on <local drive letter:>\MIP Share\Setup folder.



Chapter 9: Help Documentation

This chapter describes how to access theMIP help documentation.

Accessing Documentation
The Installation andGetting Started guides are provided with your new system. Other guides and help files

are automatically installed as part of the Server Installation process. Therefore, documentation is now

easily accessible to all workstations through the \MIP Share\MIP Documentation\PDFs directory and the

\Program Files\MIP\Help directory.

Some product guides are available in PDF format. You can access these PDF files using Help>Product

Guides or click Help and Support>Resource Center>Product Guides on the Navigation pane. These PDF

files can be viewed and printed using a program, such as the Adobe® Reader®. To install Adobe Reader,

you can download it for free from http://www.adobe.com/.

The online help's “context-sensitive” feature is an easy way to get help when you need it most. Context-

sensitivemeans that the system knows where you are working within the system so when you need

help, you can press the F1 key or click the Help button. There is a wealth of information available that you

can use daily to help you in your work. By experimenting with online help, you learn to use the system

quickly, effectively, and efficiently.

MIP Fund Accounting

Installation Guide

53

http://www.adobe.com/


Chapter 10: Supplemental Maintenance

The following information is useful for backing up, restoring, and compressing your organizational database.

Backing Up Organization Database
You can back up and restore all organization databases and the system database (NPSSQLSYS) for the

current version. When running a backup, the system creates an uncompressed copy of the database.

You can back up any database while users are in the system. However, to restore a database, all users

must exit the system.

1. As the Administrator, log on toMIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting). You do not have to select an Organization.

2. Open the File>Backup form.

3. Select the database you want to back up from the Database to Backup drop-down list.

4. Accept the default name (the database name, date, and time) or enter another name in the Backup to

File box.

5. If needed, click the Browse button and select the backup directory.

6. Click the Start button. The system backs up the database.

7. A dialog box will indicate the location of the backup when the process is finished.

Restoring Organization Database
1. As the Administrator, log on toMIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting). You do not have to select an Organization.

2. Open the File>Restoreform.

3. Select the database to restore from the drop-down list. If this is the first time a database has been

restored, its name is not available in the drop-down list; youmust enter a name here.

4. Enter the name in the Restore to File box.

5. Click the Browse button to locate the file.

6. Click the Start button.

MIP Fund Accounting

Installation Guide

54



Chapter 10: Supplemental Maintenance

MIP Fund Accounting

Installation Guide

55

The path to theMDF file that you backed up is stored in the backup file. When attempting to restore the

backup file, the system looks for the same path.

Compressing Organization Database
Before starting the compress process, all users must exit the system.

1. As the Administrator, log on toMIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting), but do not select an Organization.

2. Open the File>Compress form.

3. Select the database to compress from the drop-down list.

4. Click the Start button.

Note: Compressing large databases can take quite some time. If the actual database file has spaces in

the name, the compression program will not work.
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