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Chapter 1: Getting Started

This guide includes combined instructions for both New and Upgrade installations of the MIP Fund 

Accounting Human Resources (HR) Management Module.

New Installation Scenarios

HR Management must be installed on every workstation that needs to access the HR module. MIP Fund 

Accounting workstation is required and must be installed and accessed at least once prior to installing HR 

Management. There is no need to install the HR module on the network server or on the MIP Fund 

Accounting server unless they are also a workstation. 

Upgrade Installation Scenarios

 You are upgrading an existing standalone or network installation. Your installation will upgrade if you 

have a previous version installed. 

 See Chapter 3 for specific information regarding existing users.

Chapter Overview
This guide takes you through the Human Resource Management module installation. You will learn 

specific information about this component and how to install/upgrade it. 

The chapters in this guide are outlined as follows:

Chapter 1: Getting Started - This chapter outlines important information and procedures that need to be 

performed before running the installation programs. Read this chapter before installing.

Chapter 2: New User - Installation - Includes specific instructions about installing and running the HR 

Management program.

Chapter 3: Existing User - Upgrade – Includes useful procedures for existing users who are upgrading 

from a previous version of HR Management.

Chapter 4: HR Notifications – Installation - includes specific instructions about installing and running the 

HR Notificiations program

Chapter 5: Uninstalling HR Management - Outlines how to uninstall the HR Management program.
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Chapter 6: HR Management Documentation - Provides instructions about accessing the HR 

Management documentation.

Chapter 7: Supplemental Maintenance - Provides instructions about backing up and restoring your MIP 

Fund Accounting database, which is also your HR Management database.

Before You Begin

For optimum results, perform the following tasks before running the installation program:

 1. Verify that your current system environment meets the latest system requirements. See System 

Requirements for more information.

 2. Verify that you have MIP Fund Accounting, as well as, the Payroll or Payroll Link module installed 

(and have accessed the system at least once). These are required to be able to install the HR 

Management module.

 3. After Windows has restarted, shut down any applications that have opened at startup. Additionally, 

you may need to disable some applications, such as Norton Antivirus©.

 4. Before you begin the HR Management install, you must ensure the following:    

 The user logged on to the workstation must be a member of the Local Administrators group and 

should be the same user as the person who will be using the product.

 Windows 8.1   or 10 Users: Each workstation has at the very least write access to the 

“ProgramData” folder--<local drive letter:>\ProgramData. 

 HR Management cannot install successfully without the MIP Fund Accounting Share folders and 

corresponding access rights. 

 Access to the email sent to you by MIP to download the necessary files related to the MIP HR 

Management Install.

After performing these steps, you are ready to run the Installation program. 

System Requirements
The latest system requirements are available on the MIP Fund Accounting website. You should meet or 

exceed the MIP Fund Accounting system requirements for the MIP HR Management module.

Important! Our System Requirements have changed; SQL Server 2008 is no longer supported. 

Please verify that you are using an acceptable SQL Server version.

http://www.abila.com/solutions/fund-accounting-100


Chapter 2: New Users - Installation

This chapter describes the installation process for HR Management. You must have the MIP Fund 

Accounting workstation installed (and accessed at least once) on each workstation that will be installing 

HR Management. The download file contains the executables (SETUP.EXE and SETUP.MSI) for the HR 

Management installation and you must use Internet Explorer as your browser. 

Installing HR Management
This section describes the installation process for the HR Management module. Please carefully read 

each panel of the wizard during installation.

Notes: 
 Remember that the latest version of MIP Fund Accounting must be installed before installing HR 

Management.

 Also, if both the MIP Fund Accounting and HR Management software are installed on this workstation, 

the MIP Fund Accounting Navigation Pane has a link to the HR Management system. When the link is 

clicked HR Management opens in a separate window to the logon screen.

 1. Be sure you are logged in as a user who has local administrator rights to perform the install. Also, 

verify that you are a user with Administrator rights on the SQL Server or have access to the SQL 

Server System Admin (SA) password. (If you are not an Administrator on the SQL Server nor have 

the SA password, you will not be able to install the software.)

 2. Open the email sent to you by MIP and click the download link to the latest HR Management file. 

 3. A File Download – Security Warning form displays. Click Save to save this application in a location of 

your choice.

 4. Extract the saved file to a location on the workstation and open the folder in Windows Explorer.

 5. Right-click the Setup.exe file and select Run as administrator to start the installation wizard.

Important! Windows OS Users: If the User Account Control is turned on, a message displays: “Do 

you want to allow the following programs to make changes to this computer?” Click Yes to proceed.

 6. The Abila  HR Management InstallShield Wizard prepares to install. The Welcome panel displays. 
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 7. Click Next to confirm the installation and follow the instructions in the installation wizard. The system 

automatically downloads files to your hard disk. Or, click Cancel to exit the installation process.

 8. Click Install to begin. Use the Back button to make changes or click Cancel to exit the installation 

process.

 9. Once the Installation is complete, click Finish.

 10. Double-click the HR Management icon, located on your desktop, and enter the activation code you 

received when you purchased the HR Management module, and click Next.

 11. After you enter your activation code, an Employee License Allocation panel displays.



Installing HR Management

 12. Verify the HR Count and EWS Count for the MIP Fund Accounting Database Name. You may need to 

arrange the counts if other databases are owned and used or if you are using it for select processing 

groups.

 13. Click OK to close the panel.

 14. You will be prompted to log in.

 Enter the user ID and password provided to you by MIP when you purchased the product. If you do 

not know the user ID and password, contact your business care representative or the MIP 

Professional Services (PSG).

 For the Select an Organization, accept the default or select another MIP Fund Accounting 

organization database from the drop-down list. 

 15. Click OK.

 16. If this is the first workstation to receive the installation, a message displays “Do you want to add HRMS 

to this database?” Click Yes, to connect the HR Management tables to your organizational database.

The new HR Management module is now installed and connected to your MIP Fund Accounting 

database. 

Note: Remember, the HR Management installation must be performed on each workstation that 

needs to run HR Management.

Important! If you own the MIP Employee Web Services module, you must perform a separate 

upgrade for it as well.  It is recommended that you perform both updates (to HR Management and 

EWS) at the same time.
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 17. Optional, install MIP HR Notificiations on your workstation. For more information, see  

HR Notificiations Install.

../Common Topics/NotificationsInstall.htm


Chapter 3: Existing User - Upgrading

Use the information in this chapter to upgrade an existing installation of HR Management. It explains how 

to check for updates for the existing version if the software was downloaded using Internet Explorer.

Upgrading from a Previous Version
This section describes the upgrade process for the HR Management module. Please carefully read each 

panel of the wizard during installation.

Notes: 
 Remember that the latest version of MIP Fund Accounting must be installed prior to installing HR 

Management.

 Also, if both the MIP Fund Accounting and HR Management software are installed on this workstation, 

the MIP Fund Accounting Navigator Pane has a link to the HR Management system. When the link is 

clicked HR Management opens in a separate window to the logon screen.

 1. Be sure you are logged in as a user who has local administrator rights to perform the install. Also, 

verify that you are a user with Administrator rights on the SQL Server or have access to the SQL 

Server System Admin (SA) password. (If you are not an Administrator on the SQL Server nor have 

the SA password, you will not be able to install the software.)

 2. Uninstall HR Management.

 a. Go to Start>Settings>Control Panel.

 b. Click Programs and Features.

 c. Select Abila  HR Management, and then click Uninstall.

 3. Open the email sent to you by MIP for the new version of HR Management and click the download 

link.

 4. A File Download – Security Warning form displays. Click Save to save the zip file to the workstation.

 5. Extract the saved file to a location on the workstation and open the HR folder in Windows Explorer.

 6. Double-click the Setup.exe file to start the installation wizard.
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Important! Windows OS Users: If the User Account Control is turned on, a message displays: “Do 

you want to allow the following programs to make changes to this computer?” Click Yes to 

proceed.

 7. The Abila  HR Management InstallShield Wizard prepares to install. The Welcome panel displays.

 8. Click Next  to confirm the installation and follow the instructions in the installation wizard. The system 

automatically downloads files to your hard disk. Or, click Cancel to exit the installation process.

 9. Click Install to begin,  use the Back button to make changes or, click Cancel to exit the installation 

process.                    

 10. Once the Installation is complete, click Finish.

 11. If HR Management does not automatically launch, you can double-click the desktop icon  to open the 

application. The application prompts you to sign in.



Upgrading from a Previous Version

 Enter your user ID and password. If you do not know the user ID and password, contact your 

business care representative or the MIP Professional Services (PSG).

 For the Select an Organization, accept the default or select another MIP Fund Accounting 

organization database from the drop-down list. 

 12. Click OK.

 13. A message displays, Do you want to upgrade your HR Management database to version 2021.x?

 14. Click Yes to begin the upgrade process.

The upgraded HR Management module is now installed and connected to your MIP Fund Accounting 

database. 

Note: Remember, the HR Management installation must be performed on each workstation that 

needs to run HR Management.

Important! If you own the MIP Employee Web Services module, you must perform a separate 

upgrade for it as well. To upgrade EWS, you must uninstall the existing version and reinstall the 

updated software version. It is recommended that you perform both updates (to HR Management 

and EWS) at the same time.

 15. Optional, install MIP HR Notificiations on your workstation. For more information, see  HR Notificiations 

Install.
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Chapter 4: HR Notificiations Install

This chapter describes the installation process for HR Notificiations. You must have the MIP Fund 

Accounting  and the HR Management systems installed. The download file contains the executables 

(SETUP.EXE and SETUP.MSI) for the HR Notificiations installation.

Installing HR Notificiations
This sections described the installation process for the  HR Notificiations module. Please carefully read 

each panel of the wizard during installation.

Note: Remember that the latest version of MIP Fund Accounting and HR Management must be 

installed prior to installing HR Notificiations.

 1. Open the HR Management module, using the Help menu, click on Download HR Notificiations. This 

opens your web browser to the HR Notificiations for 2021.x page on the MIP Knowledgebase. You 

must login and have a current support plan, in order to click the link to download the file.

 2. A File Download – Security Warning form displays. Click Save to save this application in a location of 

your choice.

 3. Extract the saved file to a location on the MIP Fund Accounting or EWS server and open the folder in 

Windows Explorer.

 4. Right-click the Setup.exe file and select Run as administrator to start the installation wizard.

Important! Windows OS Users: If the User Account Control is turned on, a message displays: “Do 

you want to allow the following programs to make changes to this computer?” Click Yes to proceed.

 5. The HR Notificiations InstallShield Wizard prepares to install. The Welcome panel displays.  
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 6. Click Next to confirm the installation and follow the instructions in the installation wizard. The system 

automatically downloads files to your hard disk. Or, click Cancel to exit the installation process.

 7. Click Install to begin. Use the Back button to make changes or click Cancel to exit the installation 

process.

 8. Once the Installation is complete, click Finish.

You will need to click the MIP HR Notificiations icon located on your server's desktop, to open the 

application and complete the HR Notificiations setup.

Note: If you  get an error message when you open HR Notificiations. Simply, right-click the 

HR Notificiations icon and select Properties. On the Compatibility tab, under the Privilege Level 

section, select the Run this program as an administrator check box. Click OK and open 

HR Notificiations again. 

Setting Up HR Notificiations

Access this form using the  HR Notificiations icon on the desktop.

Use this form to set up and send HR Notificiations using email on a scheduled basis. Once 

HR Notificiations is connected to your SQL Server and MIP Fund Accounting database, you can set up 

and send email notices in 10 minute to 12 hour intervals. These notices could include on-boarding and 



Setting Up HR Notificiations

termination assigned to employees but maintained on Maintain>HR Processes, EWS employee leave 

requests, and EWS timesheet submissions.

HR Notificiations should to be left running at all times on the server machine. The timer is stopped when 

the server is stopped and restarts after the server is started on to the machine.

Note: If you will get an error message when you open HR Notificiations. Simply, right-click the 

HR Notificiations icon and select Properties. On the Compatibility tab, under the Privilege Level section, 

select the Run this program as an administrator check box. Click OK and open HR Notificiations again. 

Procedures

 1. Enter the SQL Server information and the MIP Fund Accounting Database name, and click the 

Connect button. Click OK to dismiss the Connection Complete message.

 2. If available, the system defaults to the SMTP Email information previously entered in the MIP Fund 

Accounting Administration module (Administration>Organization>Organization Information - Set Up 

SMTP Email Tab). Otherwise, enter the SMTP Email information and click the Test Email to verify 

connection. Look in your in box for the email from your system.

 3. Once the SQL Server and SMTP Email are setup and running, begin selecting the notification options. 

Select the check box to activate the notification options, and clear the check box to deactivate. You 

can always modify your selections but you will need to click the Update Options button after wards.

 4. Next, schedule how often you want to the system to check for notifications and send them out. Simply 

click the  Stop button in the Scheduling group box, in order to modify the start date and time and the 

email interval in minutes. 

 5. Once your defaults are set, click the Save button.

 6. Click the Start button to begin checking for notifications to be sent. Once the Start button is clicked, 

click OK to acknowledge the Timer is started message, and the form will minimize to the task bar. The 

system begins checking the Email Log and starts sending emails. 

 7. Click the Email Log button to view the notifications that have been created and if the email or 

notification has been sent. If an error occurs, you can view the error message.

Fields 
SQL Server: Complete the following information and click the Connect button. You must enter the 

SQL Server information to successfully connect the HR Notificiations with the SQL Server and MIP Fund 

Accounting Organization Database.
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 Server Name: Enter the Server Name for your organization's SQL Server.

 User: Enter the System Administrator's user name. 

 Password: Enter the System Administrator's password. 

 Database: Enter the name of the MIP Fund Accounting organization's database. 

 Connect: Click this button to connect the HR Notificiations with the SQL Server and MIP Fund 

Accounting Organization Database. Once the connection completes, a message displays; click OK to 

close this message. 

Scheduling: Complete the following to specify when and how often the HR Notificiations contacts the 

MIP Fund Accounting server to check the Email Log for any new notifications before sending out email 

notices. With the Scheduling Stopped, you can modify the start date and time and the email interval in 

minutes. To begin checking the Email Log, sending emails, and minimize the HR Notificiations form, 

click the Start button. 

 Start Date and Time: Accept the default start date and time or enter the time and date when 

HR Notificiations checking the Email Log and sending new emails.

 Email Interval in Minutes: Specify how often HR Notificiations should check the Email Log between 

sending new emails. The time interval must be in minutes from 10 to 720.

 Process Count: This is the number of times HR Notificiations has checked the Email Log for any new 

emails.

 Start: Click this button to being checking the Email Log and start sending emails. Once the Start 

button is clicked, click OK to acknowledge the Timer is started message, and the form will minimize to 

the task bar. The system begins checking the Email Log and starts sending emails.

 Stop: Click this button to stop sending emails. After the scheduling has stopped, you can make 

modifications to the start date and time and the email intervals in minutes. Also, notifications will still 

be created if the check boxes for the notification options are checked. Note that you will need to click 

the Start button to resume sending emails.

SMTP Email Setup: Enter the following information to configure the SMTP (Simple Mail Transfer 

Protocol) connection for emailing HR Notificiations. This is required to send emails from HR 

Management and EWS.



Setting Up HR Notificiations

Note: Once your are connected to the HR Notificiations module, The SMTP Email Setup section will 

display your MIP Fund Accounting SMTP Email information (Administration>Organization>Organization 

Information - SMTP Email Tab), if it was previously configured. 

 Server: Enter the server name of the SMTP service used to process outgoing email, for example 

SMTP.gmail.com

 User: Enter the user name associated with the SMTP service.

 Password: Enter the User's password.

 Port: Enter the port that accepts outgoing mail requests. This port number should match the port 

configured on your SMTP service. By default, the system displays 25 as the port number.

 Enable SSL: If your SMTP service supports SSL (Secure Sockets Layer), select this check box to 

securely send email notifications.

Note: The HR Notificiations emails for HR Processes will be sent using the HR Contact's email address. 

The Timesheet Submitted and Leave Requests will be sent using the employee's email address. You 

can view and/or change the HR Contact From email address in the Options group box or on the 

HR Management>Options>Settings>System Preferences form.

 Test Email Address: The From and To addresses will be used when the Test Email button is clicked. It 

is recommended that you test the SMTP Connection to make sure the information was set up correctly.

 From: Enter an email address to test where the email is coming from. If the email fails, this is the 

address that will receive the failure notification.

 To: Enter an email address to test where the email will be received. If the email is successful, this is 

the address that will receive the test email.

 Test Email: Click this button to test the email connection. If you entered From and To email 

addresses, the system will use them to test the connectivity with the Server. If the From and To email 

address fields are left blank, no test will be conducted.                    

Note: We recommend referring to your IT Technical or System Administrator for help completing the 

SMTP Email Setup information.

Options: Select the options below to have the HR Notificiations create emails and to view and/or change 

the HR Contact From email address.

 Notify when Add record in HR Processes: Select this check box to be notified when Send Email is 

selected in the HR Processes tab and it is added to an employee's record. If you want to deactivate it, 

MIP Fund Accounting

Human Resource Management Installation Guide

14



Chapter 4: HR Notificiations Install

MIP Fund Accounting

Human Resource Management Installation Guide

15

clear the check box and click the Update Options button.

 Notify when Add record in Leave Request: Select this check box to be notified when an employee in 

the EWS module submits a leave request. If you want to deactivate it, clear the check box and click the 

Update Options button.

 Notify when Add Record for Timesheet Submission: Select this check box to be notified when an 

employee in the EWS module submits a timesheet. If you want to deactivate it, clear the check box 

and click the Update Options button.

 HR Contact From Email Address: The HR Contact email address displays, which is used for 

HR Process notifications. The HR Contact information is located on the 

HR Management>Options>Settings>System Preferences form.

 Update Options: Click this button to update your notification option changes in the system.

Email Log: Click this button to open the Email Log form and view all email notification that have been 

attempted. For more information, see "Email Log" (page 15).

Save: Click this button to save your default settings. 

Email Log

Access this form using the Email Log button on the HR Notificiations form.

Use this form to view the types of HR Notificiations being sent through the system. 

Highlight the row to delete. This log is modifiable and can be changed. If you clear the Email sent check 

box, the message can be sent again within the next email interval.

Fields 
Email Log Table: The system displays the records by type, the associated Employee ID, the TypeID, the 

Task ID, the Subject and Message, and to whom the notice was sent and from. Also included is the date 

the notice was sent, if the email was sent, who created it,  if there was a send error and what associated 

error message, if applicable.

 Record Type: The system displays the record type.

 Employee ID: The system displays the associated employee ID.

 Type ID: The system displays the record type ID.

 Task ID: The system displays the task ID.
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 Subject Text: The system displays the subject line of the notification.

 Message Text: The system displays the message included in the notification.

 Sent Address: The system displays the To email address - to whom the notice was sent.

 From Address: The system displays the From email address - who the notice was from.

 Send Date: The system displays the date the notice was created or will be sent.

 Email Sent: The system displays if the email notice was sent. If the check box is not selected, the notice 

has not been sent.

 Created: The system displays the user who created the email notice.

 Send Error: The system displays if there was an error trying to send the notice. If the check box is 

selected, an error message will also display.

 Error Message: The system displays an error message if the Send Error check box was selected.
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Chapter 5: Uninstalling HR Management

This chapter describes how to uninstall the HR Management and HR Notificiations modules.

Steps to Uninstall HR Management
 1. Go to Start>Settings>Control Panel.

 2. Click Add or Remove Programs or Programs and Features, depending on your Windows version.

 3. Select Abila  HR Management, and then click Uninstall.

 4. Click Yes to confirm you want to uninstall the product. 

Steps to Uninstall HR Notificiations
 1. Go to Start>Settings>Control Panel.

 2. Click Add or Remove Programs or Programs and Features, depending on your Windows version.

 3. Select Abila  HR Notificiations, and then click Uninstall.

 4. Click Yes to confirm you want to uninstall the product. 
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Chapter 6: HR Documentation

This chapter describes how to access the HR Management documentation.

Accessing Documentation
The HR Management Human Resource Management Installation Guide is available for download on the  

MIP Fund Accounting Knowledgebase. The help files and product manuals are also automatically 

installed as part of the installation process. Therefore, documentation is now easily accessible to all 

workstations through the Help>Contents, Help>Index, or Help>Manuals on the main menu.

 The online help is an easy way to get help when you need it most. On a form, you can press the F1 key 

to display the Online Help information for that form. There is a wealth of information available that you 

can use daily to help you in your work. By experimenting with online help, you learn to use the system 

quickly, effectively, and efficiently. 

 Some product guides are available in PDF format. You can access these PDF files using 

Help>Manuals. These PDF files can be viewed and printed using a program, such as the Adobe® 

Reader®. To install Adobe Reader, you can download it for free from http://www.adobe.com/.
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Chapter 7: Supplemental Maintenance

The following information is useful for backing up and restoring your MIP Fund Accounting database 

which is also your HR Management database. 

Backing Up Organization Database
You can back up and restore all organization databases and the system database (NPSSQLSYS) for the 

current version. When running a backup, the system creates an uncompressed copy of the database. 

You can back up any database while users are in the system. However, to restore a database, all 

users must exit the system.

 1. As the Administrator, log on to MIP Fund Accounting (Start>All Programs>Abila>MIP). You do not 

have to select an Organization. Note that the HR Management, Employee Web Services, and 

HR Notificiations modules do not have the Backup form however, they share the MIP Fund 

Accounting database and their information will be included in this process.

 2. Open the File>Backup form.

 3. Select the database you want to back up from the Database to Backup drop-down list.

 4. Accept the default name (the database name, date, and time) or enter another name in the Backup to 

File box.

 5. If needed, click the Browse button and select the backup directory.

 6. Click the Start button. The system backs up the database.

 7. A dialog box will indicate the location of the backup when the process is finished.
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Restoring the Organization Database
 1. As the Administrator, log on to MIP Fund Accounting (Start>All Programs>Abila>MIP). You do not 

have to select an Organization.

 2. Open the File>Restore form.

 3. Select the database to restore from the drop-down list. If this is the first time a database has been 

restored, its name is not available in the drop-down list; you must enter a name here.

 4. Enter the name in the Restore to File box.

 5. Click the Browse button to locate the file.

 6. Click the Start button.

Tip: The databases must have been previously backed up using File>Backup; if data was backed up 

using other software, the file cannot be restored using this form.
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