Submitted by 334 on
Symptom
When running a report that uses a custom Crystal format, you receive a ‘Page Not Found’ error when you try to view the report. If you look in the queue history, you see the error ‘The table ‘table name’ could not be found’
Cause
Tables in your Crystal format are mapped improperly or the table properties are improperly set for a new database.
Resolution
Using Crystal, follow the steps below on each custom report format.
A.  For Crystal formats using views instead of tables:
  1. Open Crystal Report (.rpt) file
  2. Go to Database > Set Datasource Location
  3. Open up your connection to your database,
  4. Click on the Connection (Web SQL) in the top window
  5. Click your location in the bottom window (Web SQL)
  6. Click ‘Update’
Note: Repeat the procedure for any Sub Reports
 


B.  For Crystal formats using tables instead of views: 
  1. Open up your connection to your database
  2. Click on the table listed under the connection (Web SQL, address table)
  3. Click your location in the bottom window and expand down to open the views
  4. Highlight the associated view ( e.g. address_full)
  5. Click ‘Update’
Note: Repeat the procedure for all tables. You do not have to do this for lookup tables (e.g. campaigns, chart_of_accounts, constituent_types)



C.  If you have reset the Datasource in the report and you continue to receive the error when you run the report, open the Crystal format and make the additional changes below:
  • Make sure the Web SQL Datasource is pointed to the GENERIC table
  • If you are running the report from a saved worktable, make sure that all users who use this format have rights to the saved worktable
 
  1. Open Crystal Report (.rpt) file
  2. Go to Database > Set Datasource Location
  3. Under Current Data Source > expand the Datasource for the primary report > expand Properties
  4. Highlight the line ‘Use DSN Default Properties: False’ by clicking on the line once
  5. Click on the line again to edit the text
  6. Change ‘False’ to ‘True’ so the setting reads ‘Use DSN Default Properties: True’
  7. You will then be prompted to log into your connection: enter your information > click Finish
Note: Repeat steps 1-4 for all sub reports, and then save the report  
  1. Reset the IIS
 
 
Article Type
Product Issue
Product Line
Millennium
Product Module/Feature
Reporting
Ranking
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