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Symptom

Bookmarks do not show up under Favorites>Bookmarks for any user.

Cause

Millennium uses the setting for “Search Results Display” in the Tools\Display Design\Display Options screen for both
a) Search Results Display, and also
b) Favorites\Bookmarks display 

Resolution

 The issue is in the site’s display settings.
Millennium uses the setting for “Search Results Display” in the Tools\Display Design\Display Options screen for both
a) Search Results Display (obviously), and also
b) Favorites\Bookmarks display (less obviously).
 
In both cases, these settings determine which data columns should appear for the selected constituents.
Customer may have customized the “Search Results Display” to add the fields “Type” and “Pref. School” to the end of the list of data columns.
The actual edit screen where the columns are chosen work fine in the Search Results screen itself.
But when this customized list of data columns is used in Favorites\Bookmarks, the added “Type” column (Name.Type) conflicts with a column of the same name that is already in the list of fields that the system uses for the Bookmarks screen.
This results in Millennium issuing a SQL Select statement with duplicate column names which makes that SQL Select fail, which leaves the Favorites\Bookmarks screen empty.
The Solution
To get the Favorites\Bookmarks screen to work, customer will have to remove the “Type” (Name.Type) column from the “Search Results Display” setting in Tools\Display Design\Display Options screen.
This will, of course, also mean that this “Type” column will no longer show up in the actual Search Results screen where presumably they would like it to appear. Currently there is no work around for this; if they need to keep the Type column in “Search Results Display”, Favorites\Bookmarks will not rk.

Article Type
Product Issue
Product Line
Millennium
Product Module/Feature
Prospects
Product Version
2013.5
2013.4
2013.3
Ranking
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