Symptom
At login as a user other than admin the message:
Unable to connect to the database.
-1 SQLSTATE =37000
[Microsoft][ODBC SQL Server Driver][SQL Server] Cannot open database “Training” requested by the login. The login failed.
Cause
The issue has been confirmed as a product defect and has been reported to our Research and Development team
Resolution
While a full resolution is unavailable currently, we offer the following workaround(s) in the meantime follow the procedure below:
Notes:
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To update the ODBCAD32.exe connection the user will need to be a local admin
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The changes below will need to be made at each workstation
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Both User DSN and System DSN Tabs will need to be updated as shown below
In the Search box type ODBCAD32.exe then select the Utility
Step 1: Update User DSN tab
Select SageFR50 then followed by Configure
Select Next
Enter the password for the Fundraising 50 admin user – most customers change the password from the default
The default database window will look like this
Change Training to Master then remove the check box next to “Change the default database to:”
Select Next
Select Next then Finish
Select OK
Step 2: Update System DSN tab
Select FR50 in System Data Sources followed by Configure
Select Next
Enter in the Login ID field admin followed by the Fundraising 50 admin password – most customers change this from the system default
The window will look like what is highlighted in red
Select Next
Update Training to Master then remove the check next to “Change the default database to:”
Select Finish
Select OK
Select OK
Login again as the user having the issue.
This will correct other users having the same issue who login on the machine having the issue
If you have multiple workstations, this update may need to be applied if the user is receiving the same error message at login
Status: Please refer to article 911-Scheduled Fixes to determine the status of this issue
Article Type
Product Issue
Product Line
Fundraising 50
Product Module/Feature
Installation
Technical
Technical Issues
Ranking